Все задачи №24
№24

Самая длинная цепочка X

Текстовый файл 24.txt состоит не более чем из 10⁶ символов X, Y и Z. Определите максимальное количество идущих подряд символов X.

Учебная задача

Скачать файл: 24.txt. В редакторе он уже лежит рядом с кодом, открывай как на экзамене: open('24.txt').

Ответвпиши то, что вывела программа
Показать разбор
  1. Прочитай строку из файла и заведи счётчик текущей цепочки и максимум.
  2. Идёшь по символам: встретил X, увеличь счётчик и обнови максимум.
  3. Любой другой символ обнуляет счётчик.
  4. В конце выведи максимум.
s = open('24.txt').readline().strip()
k = 0
m = 0
for c in s:
    if c == 'X':
        k += 1
        m = max(m, k)
    else:
        k = 0
print(m)