Все задачи №8
№8

Сколько чисел в семеричной системе

Сколько существует семеричных пятизначных чисел, в записи которых ровно одна цифра 6 и нет двух одинаковых цифр подряд?

Источник: ФИПИ (Резервная 19.06.2025), № 23367

Ответвпиши то, что вывела программа
Показать разбор
  1. Цифры семеричной системы возьми как printable[:7] и перебирай числа через product с repeat=5.
  2. Проверь, что число не начинается с нуля: x[0] != '0'.
  3. Проверь, что шестёрка ровно одна: x.count('6') == 1.
  4. Проверь, что нет двух одинаковых цифр подряд: ни одна пара c + c не входит в x.
  5. Считай подходящие в k и напечатай его после цикла.
from itertools import product
from string import printable

k = 0
for x in product(printable[:7], repeat=5):
    x = ''.join(x)
    if x[0] != '0' and x.count('6') == 1 and all(c + c not in x for c in printable[:7]):
        k += 1
print(k)