Все задачи №8
№8

Первое слово с условием

Все пятибуквенные слова, составленные из букв А, Л, Г, О, Р, И, Т, М, записаны в алфавитном порядке и пронумерованы. Вот начало списка: 1. ААААА 2. ААААГ 3. ААААИ 4. ААААЛ 5. ААААМ 6. ААААО 7. ААААР …… Определите, под каким номером в этом списке стоит первое слово с чётным номером, которое не начинается с букв А или Г и при этом содержит в своей записи не менее двух букв Р. Примечание. Слово — последовательность идущих подряд букв, не обязательно осмысленная.

Источник: ФИПИ (Пересдача 03.07.2025), № 23554

Ответвпиши то, что вывела программа
Показать разбор
  1. Запиши буквы по алфавиту: АГИЛМОРТ. Перебирай слова через product с repeat=5.
  2. Склей слово через join и увеличивай номер n на каждом слове, подходит оно или нет.
  3. В if проверь условия: номер чётный, первая буква не А и не Г, букв Р не меньше двух.
  4. Как только слово подошло, напечатай номер и останови цикл через break.
from itertools import product

n = 0
for x in product('АГИЛМОРТ', repeat=5):
    x = ''.join(x)
    n += 1
    if n % 2 == 0 and x[0] not in 'АГ' and x.count('Р') >= 2:
        print(n)
        break