Все задачи №8
№8

Последнее слово с условием

Все пятибуквенные слова, составленные из букв С, Т, Р, О, К, А, записаны в алфавитном порядке и пронумерованы. Вот начало списка: 1. ААААА 2. ААААК 3. ААААО 4. ААААР 5. ААААС 6. ААААТ …… Определите, под каким номером в этом списке стоит последнее слово с чётным номером, которое не начинается с букв А, С или Т и при этом содержит в своей записи ровно две буквы О. Примечание. Слово — последовательность идущих подряд букв, не обязательно осмысленная.

Источник: ФИПИ (Демо 14.05.2026), № 23746

Ответвпиши то, что вывела программа
Показать разбор
  1. Запиши буквы по алфавиту: АКОРСТ. Перебирай слова через product с repeat=5.
  2. Склей слово через join и увеличивай номер n на каждом слове, подходит оно или нет.
  3. В if проверь условия: номер чётный, первая буква не А, С, Т, ровно две О.
  4. Запоминай номер каждого подходящего слова в last, после цикла напечатай его: последнее и будет ответом.
from itertools import product

n = 0
for x in product('АКОРСТ', repeat=5):
    x = ''.join(x)
    n += 1
    if n % 2 == 0 and x[0] not in 'АСТ' and x.count('О') == 2:
        last = n
print(last)