Все задачи №8
№8

Первое слово с условием

Все шестибуквенные слова, составленные из букв Г, Р, А, Н, И, Т, записаны в алфавитном порядке и пронумерованы. Вот начало списка: 1. АААААА 2. АААААГ 3. АААААИ 4. АААААН 5. АААААР 6. АААААТ …… Определите, под каким номером в этом списке стоит первое слово с нечётным номером, которое не начинается с букв А, И или Г и при этом содержит в своей записи ровно одну букву А. Примечание. Слово — последовательность идущих подряд букв, не обязательно осмысленная.

Источник: ФИПИ (ЕГКР 13.12.2025), № 25347

Ответвпиши то, что вывела программа
Показать разбор
  1. Запиши буквы по алфавиту: АГИНРТ. Перебирай слова через product с repeat=6.
  2. Склей слово через join и увеличивай номер n на каждом слове, подходит оно или нет.
  3. В if проверь условия: номер нечётный, первая буква не А, И, Г, ровно одна А.
  4. Как только слово подошло, напечатай номер и останови цикл через break.
from itertools import product

n = 0
for x in product('АГИНРТ', repeat=6):
    x = ''.join(x)
    n += 1
    if n % 2 == 1 and x[0] not in 'АИГ' and x.count('А') == 1:
        print(n)
        break