Все задачи №8
№8

Последнее слово с условием

Все пятибуквенные слова, составленные из букв С, И, М, В, О, Л, записаны в алфавитном порядке и пронумерованы. Вот начало списка: 1. ВВВВВ 2. ВВВВИ 3. ВВВВЛ 4. ВВВВМ 5. ВВВВО 6. ВВВВС …… Определите, под каким номером в этом списке стоит последнее слово с нечётным номером, которое не начинается с букв О или С и при этом содержит в своей записи ровно одну букву В и не более одной буквы С. Примечание. Слово — последовательность идущих подряд букв, не обязательно осмысленная.

Источник: ФИПИ (ЕГКР 18.04.2026), № 28929

Ответвпиши то, что вывела программа
Показать разбор
  1. Запиши буквы по алфавиту: ВИЛМОС. Перебирай слова через product с repeat=5.
  2. Склей слово через join и увеличивай номер n на каждом слове, подходит оно или нет.
  3. В if проверь условия: номер нечётный, первая буква не О и не С, ровно одна В и не больше одной С.
  4. Запоминай номер каждого подходящего слова в last, после цикла напечатай его: последнее и будет ответом.
from itertools import product

n = 0
for x in product('ВИЛМОС', repeat=5):
    x = ''.join(x)
    n += 1
    if n % 2 == 1 and x[0] not in 'ОС' and x.count('В') == 1 and x.count('С') <= 1:
        last = n
print(last)