Все задачи №8
№8

Первое слово с условием

Все пятибуквенные слова, составленные из букв А, К, Ц, Е, Н, Т, записаны в алфавитном порядке и пронумерованы. Вот начало списка: 1. ААААА 2. ААААЕ 3. ААААК 4. ААААН 5. ААААТ 6. ААААЦ …… Определите, под каким номером в этом списке стоит первое слово с чётным номером, которое не начинается с букв А, Е или К и при этом содержит в своей записи не менее двух букв Ц. Примечание. Слово — последовательность идущих подряд букв, не обязательно осмысленная.

Источник: ФИПИ (Основная 18.06.2026), № 31115

Ответвпиши то, что вывела программа
Показать разбор
  1. Запиши буквы по алфавиту: АЕКНТЦ. Перебирай слова через product с repeat=5.
  2. Склей слово через join и увеличивай номер n на каждом слове, подходит оно или нет.
  3. В if проверь условия: номер чётный, первая буква не А, Е, К, букв Ц не меньше двух.
  4. Как только слово подошло, напечатай номер и останови цикл через break.
from itertools import product

n = 0
for x in product('АЕКНТЦ', repeat=5):
    x = ''.join(x)
    n += 1
    if n % 2 == 0 and x[0] not in 'АЕК' and x.count('Ц') >= 2:
        print(n)
        break