Все задачи №8
№8

Последнее слово с условием

Все шестибуквенные слова, составленные из букв П, Л, А, Н, Е, Р, записаны в алфавитном порядке и пронумерованы. Вот начало списка: 1. АААААА 2. АААААЕ 3. АААААЛ 4. АААААН 5. АААААП 6. АААААР …… Определите, под каким номером в этом списке стоит последнее слово с нечётным номером, в записи которого не содержится ни одной из букв П или Р и при этом имеется ровно две буквы А и ровно одна буква Н. Примечание. Слово — последовательность идущих подряд букв, не обязательно осмысленная.

Источник: ФИПИ (Основная 19.06.2026), № 31146

Ответвпиши то, что вывела программа
Показать разбор
  1. Запиши буквы по алфавиту: АЕЛНПР. Перебирай слова через product с repeat=6.
  2. Склей слово через join и увеличивай номер n на каждом слове, подходит оно или нет.
  3. В if проверь условия: номер нечётный, нет П и Р, ровно две А и ровно одна Н.
  4. Запоминай номер каждого подходящего слова в last, после цикла напечатай его: последнее и будет ответом.
from itertools import product

n = 0
for x in product('АЕЛНПР', repeat=6):
    x = ''.join(x)
    n += 1
    if n % 2 == 1 and x.count('П') == 0 and x.count('Р') == 0 and x.count('А') == 2 and x.count('Н') == 1:
        last = n
print(last)