Все задачи №8
№8

Сколько слов с условием

Все шестибуквенные слова, составленные из букв Ц, В, Е, Т, О, К, записаны в алфавитном порядке и пронумерованы. Вот начало списка: 1. ВВВВВВ 2. ВВВВВЕ 3. ВВВВВК 4. ВВВВВО 5. ВВВВВТ 6. ВВВВВЦ …… Определите в этом списке количество слов с нечётными номерами, в записи которых не содержится ни одной из букв В, Е или К и при этом имеется ровно две буквы Т и ровно одна буква Ц. Примечание. Слово — последовательность идущих подряд букв, не обязательно осмысленная.

Источник: ФИПИ (Резервная 22.06.2026), № 31216

Ответвпиши то, что вывела программа
Показать разбор
  1. Запиши буквы по алфавиту: ВЕКОТЦ. Перебирай слова через product с repeat=6.
  2. Номер n увеличивай на каждом слове, а счётчик k только на подходящих.
  3. В if проверь условия: номер нечётный, нет В, Е, К, ровно две Т и ровно одна Ц.
  4. После цикла напечатай k.
from itertools import product

n = 0
k = 0
for x in product('ВЕКОТЦ', repeat=6):
    x = ''.join(x)
    n += 1
    if n % 2 == 1 and x.count('В') == 0 and x.count('Е') == 0 and x.count('К') == 0 and x.count('Т') == 2 and x.count('Ц') == 1:
        k += 1
print(k)