Все задачи №8
№8

Последнее слово с условием

Все шестибуквенные слова, составленные из букв С, О, Л, Н, Ц, Е, записаны в алфавитном порядке и пронумерованы. Вот начало списка: 1. ЕЕЕЕЕЕ 2. ЕЕЕЕЕЛ 3. ЕЕЕЕЕН 4. ЕЕЕЕЕО 5. ЕЕЕЕЕС 6. ЕЕЕЕЕЦ …… Определите, под каким номером в этом списке стоит последнее слово с нечётным номером, которое не начинается с букв Ц или Н и при этом содержит в своей записи ровно одну букву Ц и ровно одну букву Н. Примечание. Слово — последовательность идущих подряд букв, не обязательно осмысленная.

Источник: ФИПИ (Пересдача 08.07.2026), № 31354

Ответвпиши то, что вывела программа
Показать разбор
  1. Запиши буквы по алфавиту: ЕЛНОСЦ. Перебирай слова через product с repeat=6.
  2. Склей слово через join и увеличивай номер n на каждом слове, подходит оно или нет.
  3. В if проверь условия: номер нечётный, первая буква не Ц и не Н, ровно одна Ц и ровно одна Н.
  4. Запоминай номер каждого подходящего слова в last, после цикла напечатай его: последнее и будет ответом.
from itertools import product

n = 0
for x in product('ЕЛНОСЦ', repeat=6):
    x = ''.join(x)
    n += 1
    if n % 2 == 1 and x[0] not in 'ЦН' and x.count('Ц') == 1 and x.count('Н') == 1:
        last = n
print(last)