Все задачи №5
№5

Наименьшее R больше 150

На вход алгоритма подаётся натуральное число N. Алгоритм строит по нему новое число R так. 1. Строится троичная запись числа N. 2. Запись обрабатывается по правилу: а) если N делится на 3, то к записи справа дописываются две её последние троичные цифры; б) если N на 3 не делится, то остаток от деления N на 3 умножается на 5, результат переводится в троичную систему и дописывается в конец записи справа. Полученная запись — троичная запись числа R. 3. R переводится в десятичную систему и выводится на экран. Например, для N = 11₁₀ = 102₃ получается 102101₃ = 307₁₀, а для N = 12₁₀ = 110₃ получается 11010₃ = 111₁₀. Укажите наименьшее R, большее 150, которое может получиться в результате работы алгоритма. В ответе запишите R в десятичной системе.

Источник: ФИПИ (Основная 11.06.2025), № 23264

Ответвпиши то, что вывела программа
Показать разбор
  1. Напиши to_base(x, c) и получи троичную запись строкой: t = to_base(n, 3).
  2. Если N делится на 3, допиши срез t[-2:]. Иначе допиши в конец троичную запись n % 3 * 5.
  3. Переведи строку обратно: int(t, 3). Сверь f с примерами из условия.
  4. Спрашивают R: выведи наименьшее f(n), которое больше 150.
  5. Перебирай N с запасом, до 10000, и ответ бери из генератора через min или max.
def to_base(x, c):
    s = ''
    while x != 0:
        s = str(x % c) + s
        x = x // c
    return s

def f(n):
    t = to_base(n, 3)
    if n % 3 == 0:
        t = t + t[-2:]
    else:
        t = t + to_base(n % 3 * 5, 3)
    return int(t, 3)

print(min(f(n) for n in range(1, 10000) if f(n) > 150))