Все задачи №5
№5

Наибольшее N при R меньше 100

На вход алгоритма подаётся натуральное число N. Алгоритм строит по нему новое число R так. 1. Строится троичная запись числа N. 2. Запись обрабатывается по правилу: а) если N делится на 3, то к записи слева дописывается 1, а справа — 02; б) если N на 3 не делится, то остаток от деления N на 3 умножается на 4, результат переводится в троичную систему и дописывается в конец записи справа. Полученная запись — троичная запись числа R. 3. R переводится в десятичную систему и выводится на экран. Например, для N = 11₁₀ = 102₃ получается 10222₃ = 107₁₀, а для N = 12₁₀ = 110₃ получается 111002₃ = 353₁₀. Укажите наибольшее N, при котором R получается меньше 100. В ответе запишите N в десятичной системе.

Источник: ФИПИ (Резервная 19.06.2025), № 23364

Ответвпиши то, что вывела программа
Показать разбор
  1. Напиши to_base(x, c) и получи троичную запись строкой: t = to_base(n, 3).
  2. Если N делится на 3, допиши 1 слева и 02 справа. Иначе допиши в конец троичную запись n % 3 * 4.
  3. Переведи строку обратно: int(t, 3). Сверь f с примерами из условия.
  4. Спрашивают N: выведи наибольшее n, при котором f(n) меньше 100.
  5. Перебирай N с запасом, до 10000, и ответ бери из генератора через min или max.
def to_base(x, c):
    s = ''
    while x != 0:
        s = str(x % c) + s
        x = x // c
    return s

def f(n):
    t = to_base(n, 3)
    if n % 3 == 0:
        t = '1' + t + '02'
    else:
        t = t + to_base(n % 3 * 4, 3)
    return int(t, 3)

print(max(n for n in range(1, 10000) if f(n) < 100))