Все задачи №5
№5

Наибольшее N при R меньше 30

На вход алгоритма подаётся натуральное число N. Алгоритм строит по нему новое число R следующим образом. 1. Строится двоичная запись числа N. 2. Далее эта запись обрабатывается по следующему правилу: а) если число чётное, то к двоичной записи числа слева дописывается 10; б) если число нечётное, то к двоичной записи числа слева дописывается 1 и справа дописывается 01. Полученная таким образом запись является двоичной записью искомого числа R. 3. Результат переводится в десятичную систему и выводится на экран. Например, для исходного числа 4₁₀ = 100₂ результатом является число 10100₂ = 20₁₀, а для исходного числа 5₁₀ = 101₂ это число 110101₂ = 53₁₀. Укажите максимальное число N, после обработки которого с помощью этого алгоритма получается число R, меньшее, чем 30. В ответе запишите это число в десятичной системе счисления.

Источник: ФИПИ (Пересдача 03.07.2025), № 23551

Ответвпиши то, что вывела программа
Показать разбор
  1. Получи двоичную запись строкой: b = bin(n)[2:].
  2. Чётное N: 10 слева. Нечётное: 1 слева и 01 справа.
  3. Переведи строку обратно: int(b, 2). Сверь f с примерами из условия.
  4. Спрашивают N: выведи наибольшее n, при котором f(n) меньше 30.
  5. Перебирай N с запасом, до 10000, и ответ бери из генератора через min или max.
def f(n):
    b = bin(n)[2:]
    if n % 2 == 0:
        b = '10' + b
    else:
        b = '1' + b + '01'
    return int(b, 2)

print(max(n for n in range(1, 10000) if f(n) < 30))