Все задачи №5
№5

Наименьшее N при R не меньше 200

На вход алгоритма подаётся натуральное число N. Алгоритм строит по нему новое число R следующим образом. 1. Строится двоичная запись числа N. 2. Далее эта запись обрабатывается по следующему правилу: а) если число N делится на 3, то к этой записи дописываются её три последние двоичные цифры; б) если число N на 3 не делится, то остаток от деления умножается на 3, переводится в двоичную запись и дописывается в конец числа. Полученная таким образом запись является двоичной записью искомого числа R. 3. Результат переводится в десятичную систему и выводится на экран. Например, для исходного числа 12₁₀ = 1100₂ результатом является число 1100100₂ = 100₁₀, а для исходного числа 4₁₀ = 100₂ это число 10011₂ = 19₁₀. Укажите минимальное число N, после обработки которого с помощью этого алгоритма получается число R, не меньшее 200.

Источник: ФИПИ (Демо), № 23742

Ответвпиши то, что вывела программа
Показать разбор
  1. Получи двоичную запись строкой: b = bin(n)[2:].
  2. Если N делится на 3, допиши срез b[-3:]. Иначе допиши bin(n % 3 * 3)[2:].
  3. Переведи строку обратно: int(b, 2). Сверь f с примерами из условия.
  4. Спрашивают N: выведи наименьшее n, при котором f(n) не меньше 200.
  5. Перебирай N с запасом, до 10000, и ответ бери из генератора через min или max.
def f(n):
    b = bin(n)[2:]
    if n % 3 == 0:
        b = b + b[-3:]
    else:
        b = b + bin(n % 3 * 3)[2:]
    return int(b, 2)

print(min(n for n in range(1, 10000) if f(n) >= 200))