Все задачи №5
№5

Наименьшее нечётное R больше 208

На вход алгоритма подаётся натуральное число N. Алгоритм строит по нему новое число R следующим образом. 1. Строится троичная запись числа N. 2. Далее эта запись обрабатывается по следующему правилу: а) если число N делится на 3, то к этой записи справа дописываются две последние троичные цифры; б) если число N на 3 не делится, то вычисляется сумма цифр полученной троичной записи, эта сумма умножается на 3, переводится в троичную систему счисления и дописывается в конец числа. Полученная таким образом запись является троичной записью искомого числа R. 3. Результат переводится в десятичную систему и выводится на экран. Например, для исходного числа 8₁₀ = 22₃ результатом является число 22110₃ = 228₁₀, а для исходного числа 9₁₀ = 100₃ это число 10000₃ = 81₁₀. Укажите минимальное нечётное число R, большее 208, которое может быть получено с помощью описанного алгоритма. В ответе запишите это число в десятичной системе счисления.

Источник: ФИПИ (ЕГКР 13.12.2025), № 25344

Ответвпиши то, что вывела программа
Показать разбор
  1. Напиши to_base(x, c) и получи троичную запись строкой: t = to_base(n, 3).
  2. Если N делится на 3, допиши срез t[-2:]. Иначе посчитай сумму цифр, умножь на 3, переведи в троичную и допиши.
  3. Переведи строку обратно: int(t, 3). Сверь f с примерами из условия.
  4. Спрашивают R: добавь в условие и f(n) > 208, и f(n) % 2 == 1, выведи наименьшее.
  5. Перебирай N с запасом, до 10000, и ответ бери из генератора через min или max.
def to_base(x, c):
    s = ''
    while x != 0:
        s = str(x % c) + s
        x = x // c
    return s

def sum_digits(t):
    s = 0
    for c in t:
        s = s + int(c)
    return s

def f(n):
    t = to_base(n, 3)
    if n % 3 == 0:
        t = t + t[-2:]
    else:
        t = t + to_base(sum_digits(t) * 3, 3)
    return int(t, 3)

print(min(f(n) for n in range(1, 10000) if f(n) > 208 and f(n) % 2 == 1))