Все задачи №5
№5

Наибольшее N при R не больше 19

На вход алгоритма подаётся натуральное число N. Алгоритм строит по нему новое число R следующим образом. 1. Строится двоичная запись числа N. 2. Далее эта запись обрабатывается по следующему правилу: а) если сумма цифр в двоичной записи числа чётная, то к этой записи справа дописывается 0, а затем два левых разряда заменяются на 10; б) если сумма цифр в двоичной записи числа нечётная, то к этой записи справа дописывается 1, а затем два левых разряда заменяются на 11. Полученная таким образом запись является двоичной записью искомого числа R. 3. Результат переводится в десятичную систему и выводится на экран. Например, для исходного числа 6₁₀ = 110₂ результатом является число 1000₂ = 8₁₀, а для исходного числа 4₁₀ = 100₂ это число 1101₂ = 13₁₀. Укажите максимальное число N, после обработки которого с помощью этого алгоритма получается число R, не превышающее 19. В ответе запишите это число в десятичной системе счисления.

Источник: ФИПИ (Открытый банк), № 29337

Ответвпиши то, что вывела программа
Показать разбор
  1. Получи двоичную запись строкой: b = bin(n)[2:].
  2. Смотри на b.count('1') % 2: при чётной сумме допиши 0 и замени два левых разряда на 10, при нечётной допиши 1 и замени их на 11. Замена это '10' + b[2:].
  3. Переведи строку обратно: int(b, 2). Сверь f с примерами из условия.
  4. Спрашивают N: выведи наибольшее n, при котором f(n) не больше 19.
  5. Перебирай N с запасом, до 10000, и ответ бери из генератора через min или max.
def f(n):
    b = bin(n)[2:]
    if b.count('1') % 2 == 0:
        b = b + '0'
        b = '10' + b[2:]
    else:
        b = b + '1'
        b = '11' + b[2:]
    return int(b, 2)

print(max(n for n in range(1, 10000) if f(n) <= 19))