Все задачи №5
№5

Наименьшее R при N не меньше 17

На вход алгоритма подаётся натуральное число N. Алгоритм строит по нему новое число R следующим образом. 1. Строится двоичная запись числа N. 2. Далее эта запись обрабатывается по следующему правилу: а) если число чётное, то к двоичной записи числа слева дописывается 10; б) если число нечётное, то к двоичной записи числа слева дописывается 1 и справа дописывается 01. Полученная таким образом запись является двоичной записью искомого числа R. 3. Результат переводится в десятичную систему и выводится на экран. Например, для исходного числа 4₁₀ = 100₂ результатом является число 10100₂ = 20₁₀, а для исходного числа 5₁₀ = 101₂ это число 110101₂ = 53₁₀. Укажите минимальное число R, которое может быть результатом работы данного алгоритма, при условии, что N не меньше 17. В ответе запишите это число в десятичной системе счисления.

Источник: ФИПИ (Резервная 22.06.2026), № 31213

Ответвпиши то, что вывела программа
Показать разбор
  1. Получи двоичную запись строкой: b = bin(n)[2:].
  2. Чётное N: 10 слева. Нечётное: 1 слева и 01 справа.
  3. Переведи строку обратно: int(b, 2). Сверь f с примерами из условия.
  4. Спрашивают R при N не меньше 17: начни перебор с 17 и выведи наименьшее f(n).
  5. Перебирай N с запасом, до 10000, и ответ бери из генератора через min или max.
def f(n):
    b = bin(n)[2:]
    if n % 2 == 0:
        b = '10' + b
    else:
        b = '1' + b + '01'
    return int(b, 2)

print(min(f(n) for n in range(17, 10000)))