Все задачи №5
№5

Наименьшее R больше 95

На вход алгоритма подаётся натуральное число N. Алгоритм строит по нему новое число R следующим образом. 1. Строится двоичная запись числа N. 2. Далее эта запись обрабатывается по следующему правилу: а) если число N чётное, то к этой записи справа и слева дописываются по две единицы; б) если число N нечётное, то в конец двоичной записи (справа) дописываются два нуля, а в начало (слева) дописывается единица. Полученная таким образом запись (в ней на три или четыре разряда больше, чем в записи исходного числа N) является двоичной записью искомого числа R. 3. Результат переводится в десятичную систему и выводится на экран. Например, для исходного числа 13₁₀ = 1101₂ результатом является число 1110100₂ = 116₁₀, а для исходного числа 6₁₀ = 110₂ это число 1111011₂ = 123₁₀. Укажите наименьшее число R, превышающее 95, которое может быть результатом работы данного алгоритма. В ответе запишите это число в десятичной системе счисления.

Источник: ФИПИ (Демо), № 31502

Ответвпиши то, что вывела программа
Показать разбор
  1. Получи двоичную запись строкой: b = bin(n)[2:].
  2. Чётное N: по 11 слева и справа. Нечётное: 1 слева и 00 справа.
  3. Переведи строку обратно: int(b, 2). Сверь f с примерами из условия.
  4. Спрашивают R: выведи наименьшее f(n), которое больше 95.
  5. Перебирай N с запасом, до 10000, и ответ бери из генератора через min или max.
def f(n):
    b = bin(n)[2:]
    if n % 2 == 0:
        b = '11' + b + '11'
    else:
        b = '1' + b + '00'
    return int(b, 2)

print(min(f(n) for n in range(1, 10000) if f(n) > 95))