Все задачи №23
№23

Кратчайший путь из 1 в 100

В текстовом файле содержится описание ациклического ориентированного взвешенного графа. В каждой строке файла записаны два натуральных числа (L, M) и одно положительное вещественное число (W). L и M – номера вершин графа, W – вес ребра, ведущего из вершины L в вершину M. Таким образом, количество строк в файле равно количеству рёбер в графе. Две вершины графа не могут быть соединены более чем одним ребром. Найдите и запишите в ответе целую часть длины кратчайшего пути из вершины с номером 1 в вершину с номером 100. Существование хотя бы одного такого пути гарантируется. Под длиной кратчайшего пути понимается минимальная сумма весов рёбер, составляющих путь. Для выполнения этого задания следует написать программу. Вершины графа могут быть пронумерованы не подряд. L ≤ 1000, M ≤ 1000; W ≤ 10 000. Количество строк в файле не превосходит 200. Числа в строках разделены произвольным ненулевым количеством пробелов и/или табуляций. Типовой пример организации данных во входном файле для графа на рисунке.

146712100

100 12 1.0 6 7 7.0 6 1 1.0 1 7 5.5 7 100 2.0 4 100 8.0 1 100 12.0 1 4 2.5 Для приведённого примера верным ответом будет 7. Типовой пример имеет иллюстративный характер. Для выполнения задания используйте данные из прилагаемого файла.

Источник: ФИПИ (Демо 2027), № 31518

Скачать файл: task_31518_A.txt. В редакторе он уже лежит рядом с кодом, открывай как на экзамене: open('task_31518_A.txt').

Ответвпиши то, что вывела программа
Показать разбор
  1. Прочитай все рёбра из файла: откуда, куда, длина.
  2. Заведи список расстояний на 1001 элемент: в начале бесконечности, у старта 0.
  3. Проходи по всем рёбрам, пока расстояния меняются.
  4. Выведи расстояние до вершины 100 и возьми целую часть.
data = []
for line in open('task_31518_A.txt'):
    a, b, l = line.split()
    data.append([int(a), int(b), float(l)])

dist = [float('inf')] * 1001
dist[1] = 0

while True:
    old = dist.copy()
    for a, b, l in data:
        dist[b] = min(dist[b], dist[a] + l)
    if old == dist:
        break

print(int(dist[100]))