Все задачи №21
№21

Ваня выигрывает первым или вторым ходом

Два игрока, Петя и Ваня, играют в игру. Перед ними две кучи камней, ходят по очереди, первый ход делает Петя. За один ход игрок может: добавить в одну из куч 4 камня или увеличить одну из куч в 3 раза. Игра заканчивается, когда суммарное количество камней в двух кучах становится не менее 154. Выигрывает игрок, сделавший последний ход, то есть первым получивший такую позицию. В начальный момент в первой куче 11 камней, во второй S камней, 1 ≤ S ≤ 142. Игрок имеет выигрышную стратегию, если может выиграть при любых ходах противника. Найдите наименьшее значение S, при котором одновременно выполняются два условия: у Вани есть выигрышная стратегия, позволяющая ему выиграть первым или вторым своим ходом при любой игре Пети; у Вани нет стратегии, которая позволяет ему гарантированно выиграть первым ходом.

Источник: ФИПИ (Открытый банк), № 29351

Ответвпиши то, что вывела программа
Показать разбор
  1. Напиши функцию f(a, b, m), где m это число оставшихся ходов обоих игроков. Игра кончена, если a + b >= 154: тогда верни m % 2 == 0, а при m == 0 верни 0.
  2. Запиши в список h четыре хода: +4 к каждой куче и умножение каждой кучи на 3.
  3. В конце пиши any(h) при нечётном m и all(h) при чётном. Первым ходит Петя, но считаем за Ваню, поэтому число m чётное.
  4. Перебери S и оставь те, где верно not f(11, s, 2) and f(11, s, 4). Условие not f(11, s, 2) обязательно: f(11, s, 4) включает и выигрыш первым ходом.
  5. Напечатай наименьшее значение из списка.
def f(a, b, m):
    if a + b >= 154:
        return m % 2 == 0
    if m == 0:
        return 0
    h = [f(a + 4, b, m - 1), f(a, b + 4, m - 1), f(a * 3, b, m - 1), f(a, b * 3, m - 1)]
    return any(h) if m % 2 != 0 else all(h)

r = [s for s in range(1, 143) if not f(11, s, 2) and f(11, s, 4)]
print(min(r))