Все задачи №2
№2

Фрагмент таблицы истинности (F = 1)

Миша заполнял таблицу истинности логической функции F = ¬(y → (x ≡ z)) ∧ (w → x), но успел заполнить лишь фрагмент из трёх различных её строк, даже не указав, какому столбцу таблицы соответствует каждая из переменных w, x, y, z.

F
001
001
11

Определите, какому столбцу таблицы соответствует каждая из переменных w, x, y, z. В ответе напишите буквы w, x, y, z в том порядке, в котором идут соответствующие им столбцы (сначала буква, соответствующая первому столбцу; затем буква, соответствующая второму столбцу, и т.д.). Буквы в ответе пишите подряд, никаких разделителей между буквами ставить не нужно.

Источник: ФИПИ (резервный день 19.06.2025), № 23361

Ответвпиши то, что вывела программа
Показать разбор
  1. Перепиши функцию на Python: → это <=, ≡ это ==, ¬ это not, ∨ это or, ∧ это and. Ставь скобки вокруг каждой операции.
  2. Перепиши фрагмент в кортеж t, последним числом в строке ставь значение F (тут везде 1).
  3. Пустых клеток 7, заполни их всеми способами через product и отбрось варианты, где строки совпали.
  4. Через permutations перебери порядок столбцов и проверь, что f на каждой строке даёт значение из таблицы.
  5. Один порядок находится при разных заполнениях, поэтому собирай его в множество. Ответ это буквы в порядке столбцов, подряд.
from itertools import product, permutations

def f(x, y, z, w):
    return (not (y <= (x == z))) and (w <= x)

ans = set()
for a, b, c, d, e, g, h in product([0, 1], repeat=7):
    t = (
        (a, 0, 0, b, 1),
        (0, c, 0, d, 1),
        (e, 1, g, h, 1),
    )
    if len(t) == len(set(t)):
        for p in permutations('xyzw'):
            if all(f(**dict(zip(p, line))) == line[-1] for line in t):
                ans.add(''.join(p))
print(*ans)