Все задачи №17
№17

Пары, разность кратна минимальному положительному кратному 33

В файле лежит последовательность целых чисел от −100 000 до 100 000. Парой называем два соседних элемента. Найдите количество пар, в которых элементы не равны, а модуль их разности делится на минимальный положительный элемент последовательности, кратный 33 (такой элемент в последовательности гарантированно есть). В ответе запишите два числа через пробел: сначала количество найденных пар, затем наибольшую из сумм элементов таких пар.

Источник: ФИПИ (Основная 18.06.2026), № 31124

Скачать файл: task_31124_A.txt. В редакторе он уже лежит рядом с кодом, открывай как на экзамене: open('task_31124_A.txt').

Ответвпиши то, что вывела программа
Показать разбор
  1. Прочитай числа из файла в список.
  2. До цикла найди минимальный положительный элемент, кратный 33.
  3. Пройди по парам циклом до len(a) - 1 и проверь: элементы не равны, а модуль их разности делится на найденное число.
  4. Суммы подходящих пар складывай в список c.
  5. Напечатай длину списка и его максимум.
a = [int(line) for line in open('task_31124_A.txt')]
mn = min(x for x in a if x > 0 and x % 33 == 0)
c = []
for i in range(len(a) - 1):
    if a[i] != a[i + 1] and abs(a[i] - a[i + 1]) % mn == 0:
        c.append(a[i] + a[i + 1])
print(len(c), max(c))