Все задачи №17
№17

Пары, хотя бы одно отрицательное, сумма меньше числа кратных

В файле лежит последовательность целых чисел от −100 000 до 100 000. Парой называем два соседних элемента. Найдите количество пар, в которых хотя бы одно число отрицательное, а сумма чисел пары меньше количества чисел в последовательности, кратных 100. В ответе запишите два числа через пробел: сначала количество найденных пар, затем наибольшую из сумм элементов таких пар.

Источник: ФИПИ (Основная 19.06.2026), № 31155

Скачать файл: task_31155_A.txt. В редакторе он уже лежит рядом с кодом, открывай как на экзамене: open('task_31155_A.txt').

Ответвпиши то, что вывела программа
Показать разбор
  1. Прочитай числа из файла в список.
  2. До цикла посчитай, сколько чисел кратно 100. Ноль тоже кратен 100.
  3. Пройди по парам циклом до len(a) - 1 и проверь два условия: хотя бы одно число меньше нуля и сумма пары меньше найденного количества.
  4. Суммы подходящих пар складывай в список c.
  5. Напечатай длину списка и его максимум.
a = [int(line) for line in open('task_31155_A.txt')]
k = 0
for x in a:
    if x % 100 == 0:
        k += 1
c = []
for i in range(len(a) - 1):
    if (a[i] < 0 or a[i + 1] < 0) and a[i] + a[i + 1] < k:
        c.append(a[i] + a[i + 1])
print(len(c), max(c))