Все задачи №16
№16

одна функция, большое n, выражение

Алгоритм вычисления функции F(n), где n — целое число, задан соотношениями: F(n) = 1 при n < 10; F(n) = (n + 3) × F(n − 3), если n ≥ 10. Чему равно значение выражения (F(247563) / 519 − 477 × F(247560)) / F(247557)?

Источник: ФИПИ (Открытый банк), № 29348

Ответвпиши то, что вывела программа
Показать разбор
  1. Перепиши функцию из условия: F(n) = 1 при n < 10, иначе (n + 3) * F(n - 3).
  2. Значения получаются огромные, поэтому поставь @lru_cache(100): кэш держит только последние значения и не забивает память.
  3. Прогрей функцию циклом снизу вверх до самого большого нужного n. Значения F(247563), F(247560) и F(247557) запомни в переменные прямо в цикле.
  4. Все остальные n считай в ветке else: F(n). Без неё кэш не прогреется.
  5. Посчитай выражение через x1, x2, x3, оба деления пиши через //, и напечатай результат.
from functools import lru_cache

@lru_cache(100)
def F(n):
    if n < 10:
        return 1
    return (n + 3) * F(n - 3)

for n in range(10, 247564):
    if n == 247563:
        x1 = F(n)
    elif n == 247560:
        x2 = F(n)
    elif n == 247557:
        x3 = F(n)
    else:
        F(n)
print((x1 // 519 - 477 * x2) // x3)