Все задачи №16
№16

одна функция, выражение

Алгоритм вычисления функции F(n), где n — целое число, задан соотношениями: F(n) = 1 при n = 1; F(n) = (n − 1) × F(n − 1), если n > 1. Чему равно значение выражения (F(17258) + 3 × F(17257)) / F(17256)?

Источник: ФИПИ (Основная 19.06.2026), № 31154

Ответвпиши то, что вывела программа
Показать разбор
  1. Перепиши функцию из условия: F(n) = 1 при n = 1, иначе (n - 1) * F(n - 1).
  2. Значения получаются огромные, поэтому поставь @lru_cache(100): кэш держит только последние значения и не забивает память.
  3. Прогрей функцию циклом снизу вверх до самого большого нужного n. Значения F(17258), F(17257) и F(17256) запомни в переменные прямо в цикле.
  4. Все остальные n считай в ветке else: F(n). Без неё кэш не прогреется.
  5. Посчитай выражение через x1, x2, x3, деление пиши через //, и напечатай результат.
from functools import lru_cache

@lru_cache(100)
def F(n):
    if n == 1:
        return 1
    return (n - 1) * F(n - 1)

for n in range(2, 17259):
    if n == 17258:
        x1 = F(n)
    elif n == 17257:
        x2 = F(n)
    elif n == 17256:
        x3 = F(n)
    else:
        F(n)
print((x1 + 3 * x2) // x3)