Все задачи №16
№16

одна функция, факториал, выражение

Алгоритм вычисления функции F(n), где n — целое число, задан соотношениями: F(n) = 1 при n = 1; F(n) = n × F(n − 1), если n > 1. Чему равно значение выражения (F(3038) + 5 × F(3037)) / F(3036)?

Источник: ФИПИ (Демо), № 31513

Ответвпиши то, что вывела программа
Показать разбор
  1. Перепиши функцию из условия: F(n) = 1 при n = 1, иначе n * F(n - 1).
  2. Значения получаются огромные, поэтому поставь @lru_cache(100): кэш держит только последние значения и не забивает память.
  3. Прогрей функцию циклом снизу вверх до самого большого нужного n. Значения F(3038), F(3037) и F(3036) запомни в переменные прямо в цикле.
  4. Все остальные n считай в ветке else: F(n). Без неё кэш не прогреется.
  5. Посчитай выражение через x1, x2, x3, деление пиши через //, и напечатай результат.
from functools import lru_cache

@lru_cache(100)
def F(n):
    if n == 1:
        return 1
    return n * F(n - 1)

for n in range(2, 3039):
    if n == 3038:
        x1 = F(n)
    elif n == 3037:
        x2 = F(n)
    elif n == 3036:
        x3 = F(n)
    else:
        F(n)
print((x1 + 5 * x2) // x3)