Все задачи №15
№15

Равенство 78125 = y + 4x

Для какого наименьшего целого неотрицательного числа A логическое выражение (78125 ≠ y + 4x) ∨ (A > x) ∧ (A > y) истинно (т.е. принимает значение 1) при любых целых положительных x и y?

Источник: ФИПИ (ЕГКР 13.12.2025), № 25354

Ответвпиши то, что вывела программа
Показать разбор
  1. Двойной перебор тут слишком долгий: y выражается через x как 78125 - 4 * x.
  2. Формула зависит от A только на таких парах, причём ∧ выполняется раньше ∨.
  3. Для этих пар A должно быть больше и x, и y.
  4. Пройди циклом по x, бери только положительные y и находи наибольшее из x и y.
  5. A должно быть на 1 больше него, выведи это число.
best = 0
for x in range(1, 78125):
    y = 78125 - 4 * x
    if y > 0:
        best = max(best, x, y)
print(best + 1)