Все задачи №15
№15

Произведение xy, наименьшее A

Для какого наименьшего целого неотрицательного числа A выражение (x · y < A) ∨ (5 · x < y) ∨ (486 ≤ x) истинно (т.е. принимает значение 1) при любых целых неотрицательных x и y?

Источник: ФИПИ (ЕГКР 18.04.2026), № 28936

Ответвпиши то, что вывела программа
Показать разбор
  1. Двойной перебор тут слишком долгий, поэтому сначала сделай часть без A ложной.
  2. Она ложна, когда x <= 485 и y <= 5x.
  3. При таких парах должно быть x · y < A, значит важен самый большой y при каждом x: y = 5x.
  4. Пройди циклом по x от 0 до 485 и найди наибольшее произведение x · y.
  5. A должно быть на 1 больше него, выведи это число.
best = 0
for x in range(0, 486):
    y = 5 * x
    best = max(best, x * y)
print(best + 1)