Все задачи №15
№15

Неравенства x и y, наибольшее A

Для какого наибольшего целого неотрицательного числа A логическое выражение (x + y ≤ 27) ∨ (y ≤ x − 1) ∨ (y ≥ A) истинно (т.е. принимает значение 1) при любых целых положительных x и y?

Источник: ФИПИ (Резервная 22.06.2026), № 31223

Ответвпиши то, что вывела программа
Показать разбор
  1. Перепиши формулу в функцию f(x, y, A): ≤ это <=, ≥ это >=, ∨ это or.
  2. A начинается с нуля: так сказано в условии.
  3. Внутри all сделай два перебора: по x и по y от 1 до 99.
  4. Нужно наибольшее A, поэтому возьми max и выведи результат.
def f(x, y, A):
    return (x + y <= 27) or (y <= x - 1) or (y >= A)

print(max(A for A in range(0, 100)
          if all(f(x, y, A) for x in range(1, 100) for y in range(1, 100))))