Все задачи №15
№15

Вложенная импликация, НОК

Обозначим через ДЕЛ(n, m) утверждение «натуральное число n делится без остатка на натуральное число m». Для какого наибольшего натурального числа A логическое выражение ДЕЛ(x, 33) → (¬ДЕЛ(x, A) → ¬ДЕЛ(x, 242)) истинно (т.е. принимает значение 1) при любом целом положительном значении переменной x?

Источник: ФИПИ (Пересдача 08.07.2026), № 31361

Ответвпиши то, что вывела программа
Показать разбор
  1. Напиши функцию d(n, m): делится ли n на m без остатка.
  2. Перепиши формулу в функцию f(x, A): → это <=, ¬ это not, каждую импликацию бери в скобки.
  3. Перебирай A и оставляй те, при которых all(f(x, A)) истинно для всех x от 1 до 1999.
  4. Нужно наибольшее A, поэтому возьми max и выведи результат.
def d(n, m):
    return n % m == 0

def f(x, A):
    return d(x, 33) <= ((not d(x, A)) <= (not d(x, 242)))

print(max(A for A in range(1, 1000) if all(f(x, A) for x in range(1, 2000))))