Все задачи №15
№15

Сумма элементов множества

Множество P = {2, 4, 6, 8, 10, 12}, множество Q = {4, 5, 6, 7, 8}. Множество A состоит из натуральных чисел от 1 до 99. Формула (x ∈ P → x ∉ Q) ∨ (x ∈ A) тождественно истинна при любом натуральном x от 1 до 99. Какова наименьшая возможная сумма элементов множества A?

Учебная задача

Ответвпиши то, что вывела программа
Показать разбор
  1. Начни с пустого множества a.
  2. В функции f опиши P, Q и A через x in, а формулу запиши с <= и or.
  3. Иди по x от 1 до 99. Если формула ложна, этот x обязан быть в a: добавь его.
  4. Выведи сумму элементов a.
a = set()

def f(a):
    P = x in {2, 4, 6, 8, 10, 12}
    Q = x in {4, 5, 6, 7, 8}
    A = x in a
    return (P <= (not Q)) or A

for x in range(1, 100):
    if f(a) == 0:
        a.add(x)
print(sum(a))