Все задачи №15
№15

Неравенства с x и y

Для какого наименьшего натурального числа A формула (x + 2y ≠ 58) ∨ (A > 2x) ∨ (A > y) тождественно истинна при любых натуральных значениях переменных x и y?

Учебная задача

Ответвпиши то, что вывела программа
Показать разбор
  1. Перепиши формулу в функцию f(x, y, A): ≠ это !=, ∨ это or.
  2. Важны только пары, где x + 2y = 58, значит x и y не больше 58.
  3. Внутри all сделай два перебора: по x и по y от 1 до 59.
  4. Нужно наименьшее A, поэтому возьми min и выведи результат.
def f(x, y, A):
    return (x + 2 * y != 58) or (A > 2 * x) or (A > y)

print(min(A for A in range(1, 200)
          if all(f(x, y, A) for x in range(1, 60) for y in range(1, 60))))