Все задачи №14
№14

Ровно 6 нулей в 27-ричной записи

Значение арифметического выражения 3·27⁹ + 2·27⁶ + 27³ − x, где x – целое положительное число, не превышающее 27 000, записали в 27-ричной системе счисления. Определите наименьшее значение x, при котором в 27-ричной записи числа, являющегося значением данного арифметического выражения, содержится ровно 6 нулей. В ответе запишите число в десятичной системе счисления.

Источник: ФИПИ (ЕГКР 13.12.2025), № 25353

Ответвпиши то, что вывела программа
Показать разбор
  1. Перебирай x от 1 до 27000 и для каждого считай значение выражения.
  2. Разбирай его на цифры: n % 27 и n //= 27.
  3. Считай цифры, равные нулю.
  4. Как только нулей ровно 6, выведи x и останови цикл: это наименьшее значение.
for x in range(1, 27001):
    n = 3 * 27 ** 9 + 2 * 27 ** 6 + 27 ** 3 - x
    count = 0
    while n:
        if n % 27 == 0:
            count += 1
        n //= 27
    if count == 6:
        print(x)
        break