Все задачи №14
№14

Чётные цифры больше 9, основание 27

Значение арифметического выражения 2·2187⁵⁶⁷ + 729⁵⁶⁶ − 2·243⁵⁶⁵ + 81⁵⁶⁴ − 2·27⁵⁶³ − 6561 записали в системе счисления с основанием 27. Определите в 27-ричной записи числа количество цифр с чётным числовым значением, превышающим 9.

Источник: ФИПИ (Досрочная волна), № 28760

Ответвпиши то, что вывела программа
Показать разбор
  1. Запиши выражение как есть, степени через **. Само число не печатай: оно огромное.
  2. Пока число не ноль, сохраняй последнюю цифру: d = x % 27.
  3. Если d чётная и больше 9, увеличь счётчик.
  4. Отрежь цифру через x //= 27 и в конце выведи счётчик.
x = 2 * 2187 ** 567 + 729 ** 566 - 2 * 243 ** 565 + 81 ** 564 - 2 * 27 ** 563 - 6561
count = 0
while x != 0:
    d = x % 27
    if d % 2 == 0 and d > 9:
        count += 1
    x //= 27
print(count)