Все задачи №14
№14

Чётные цифры в 36-ричной записи

Определите количество цифр с чётным числовым значением в 36-ричной записи числа, заданного выражением: 5·1296²⁰²¹ − 4·216²⁰²² + 3·36²⁰²³ − 2·6²⁰²⁴ − 2025.

Источник: ФИПИ (Открытый банк), № 29346

Ответвпиши то, что вывела программа
Показать разбор
  1. Запиши выражение как есть, степени через **. Само число не печатай: оно огромное.
  2. Пока число не ноль, бери последнюю цифру как x % 36.
  3. Если цифра чётная, увеличь счётчик. Ноль тоже чётная цифра.
  4. Отрежь цифру через x //= 36 и в конце выведи счётчик.
x = 5 * 1296 ** 2021 - 4 * 216 ** 2022 + 3 * 36 ** 2023 - 2 * 6 ** 2024 - 2025
count = 0
while x != 0:
    if x % 36 % 2 == 0:
        count += 1
    x //= 36
print(count)