Все задачи №14
№14

Максимум нулей в 5-ной записи

Значение арифметического выражения 5¹⁵⁰ + 5¹⁰⁰ − x, где x – целое положительное число, не превышающее 2030, записали в 5-ричной системе счисления. Определите наибольшее значение x, при котором количество нулей в 5-ричной записи значения арифметического выражения максимально. В ответе запишите число в десятичной системе счисления.

Источник: ФИПИ (Основная 18.06.2026), № 31121

Ответвпиши то, что вывела программа
Показать разбор
  1. Перебирай x от 1 до 2030 и для каждого считай значение выражения.
  2. Разбирай его на цифры: n % 5 и n //= 5, считай нули.
  3. Храни рекорд нулей best и его x в переменной ans.
  4. Обновляй их при count >= best: при равенстве нужен больший x.
  5. После цикла выведи ans.
best = 0
ans = 0
for x in range(1, 2031):
    n = 5 ** 150 + 5 ** 100 - x
    count = 0
    while n:
        if n % 5 == 0:
            count += 1
        n //= 5
    if count >= best:
        best = count
        ans = x
print(ans)