Все задачи №14
№14

Ровно 70 нулей в 7-ной записи

Значение арифметического выражения 7¹⁷⁰ + 7¹⁰⁰ − x, где x – целое положительное число, не превышающее 2030, записали в 7-ричной системе счисления. Определите наибольшее значение x, при котором в 7-ричной записи значения данного арифметического выражения содержится ровно 70 нулей. В ответе запишите число в десятичной системе счисления.

Источник: ФИПИ (Основная 19.06.2026), № 31152

Ответвпиши то, что вывела программа
Показать разбор
  1. Перебирай x от 1 до 2030 и для каждого считай значение выражения.
  2. Разбирай его на цифры: n % 7 и n //= 7.
  3. Считай цифры, равные нулю.
  4. Если нулей ровно 70, запоминай x: каждое следующее подходящее заменит прошлое.
  5. После цикла выведи запомненное значение, это наибольшее x.
ans = 0
for x in range(1, 2031):
    n = 7 ** 170 + 7 ** 100 - x
    count = 0
    while n:
        if n % 7 == 0:
            count += 1
        n //= 7
    if count == 70:
        ans = x
print(ans)