Все задачи №14
№14

Цифра x, основание 19

Операнды арифметического выражения записаны в системе счисления с основанием 19. 76x79645₁₉ + 35x42₁₉ + 332x6₁₉ В записи чисел переменной x обозначена неизвестная цифра из алфавита 19-ричной системы счисления. Определите наибольшее значение x, при котором значение данного арифметического выражения кратно 18. Для найденного x вычислите частное от деления значения арифметического выражения на 18 и укажите его в ответе в десятичной системе счисления. Основание системы счисления указывать не нужно.

Источник: ФИПИ (Резервная 22.06.2026), № 31222

Ответвпиши то, что вывела программа
Показать разбор
  1. Перебирай x по цифрам системы: printable[:19]. Цифры идут по возрастанию, начиная с 0.
  2. Подставляй x в каждую запись через f-строку и читай её через int.
  3. Проверь, что сумма делится на 18 без остатка.
  4. Для подходящих x сохраняй частное, деление только через //.
  5. Для наибольшего x нужно последнее частное в списке, его и выведи.
from string import printable

res = []
for x in printable[:19]:
    x1 = int(f'76{x}79645', 19)
    x2 = int(f'35{x}42', 19)
    x3 = int(f'332{x}6', 19)
    if (x1 + x2 + x3) % 18 == 0:
        res.append((x1 + x2 + x3) // 18)
print(res[-1])