Все задачи №14
№14

Различные цифры

Число 6²⁰⁰ записали в системе счисления с основанием 5. Сколько различных цифр встречается в этой записи?

Учебная задача

Ответвпиши то, что вывела программа
Показать разбор
  1. Посчитай число через **.
  2. Заведи пустое множество: оно само уберёт повторы.
  3. Пока число не ноль, добавляй в множество последнюю цифру x % 5 и отрезай её через x //= 5.
  4. Выведи размер множества через len.
x = 6 ** 200
s = set()
while x != 0:
    s.add(x % 5)
    x //= 5
print(len(s))