Все задачи №14
№14

Ровно 53 нуля

Для каждого целого x от 1 до 3000 вычислили значение выражения 7·13¹⁵⁰ + 13¹⁰⁰ − 4·13³⁰ − x и записали его в системе счисления с основанием 13. Найдите x, при котором в этой записи ровно 53 нуля. Если таких x несколько, укажите наименьшее.

Учебная задача

Ответвпиши то, что вывела программа
Показать разбор
  1. Перебирай x от 1 до 3000 и для каждого считай значение выражения.
  2. Разбирай его на цифры: n % 13 и n //= 13.
  3. Считай цифры, равные нулю.
  4. Как только нулей ровно 53, выведи x и останови цикл: это наименьшее значение.
for x in range(1, 3001):
    n = 7 * 13 ** 150 + 13 ** 100 - 4 * 13 ** 30 - x
    count = 0
    while n:
        if n % 13 == 0:
            count += 1
        n //= 13
    if count == 53:
        print(x)
        break