Все задачи №14
№14

Сколько шестёрок

Значение выражения 49²⁵ + 7³⁰ − 14 записали в системе счисления с основанием 7. Сколько цифр 6 в этой записи?

Учебная задача

Ответвпиши то, что вывела программа
Показать разбор
  1. Запиши выражение как есть, степени через **.
  2. Пока число не ноль, бери последнюю цифру как x % 7.
  3. Если цифра равна 6, увеличь счётчик.
  4. Отрежь цифру через x //= 7 и в конце выведи счётчик.
x = 49 ** 25 + 7 ** 30 - 14
count = 0
while x != 0:
    if x % 7 == 6:
        count += 1
    x //= 7
print(count)