Все задачи №10
№10

Сколько существует масок

Узел с IP-адресом 45.200.64.9 находится в сети с адресом 45.200.64.0. Сколько существует различных масок, для которых это возможно?

Учебная задача

Ответвпиши то, что вывела программа
Показать разбор
  1. Перебери число единиц в маске m от 0 до 32.
  2. Для каждого m создай сеть с адресом узла и аргументом False.
  3. Сравни str(net.network_address) с адресом сети из условия.
  4. Считай, сколько масок подошло.
from ipaddress import ip_network

k = 0
for m in range(0, 33):
    net = ip_network(f'45.200.64.9/{m}', False)
    if str(net.network_address) == '45.200.64.0':
        k += 1
print(k)