Все задачи №1
№1

Сумма дорог B–A и H–A

На рисунке схема дорог изображена в виде графа, в таблице — длины этих дорог в километрах. Таблицу и схему рисовали независимо, поэтому нумерация пунктов в таблице никак не связана с буквами на графе. Определите, какова сумма длин дорог из пункта B в пункт A и из пункта H в пункт A. В ответе запишите целое число.

ABCDEFGH
П1П2П3П4П5П6П7П8
П1168
П223715
П31926
П4162325
П572538
П61938
П782619
П81519

Источник: ФИПИ (ЕГКР 18.04.2026), № 28922

Ответвпиши то, что вывела программа
Показать разбор
  1. Выпиши дороги со схемы парами букв в roads, их тут 10. Проверь: в таблице столько же дорог.
  2. Для каждой строки таблицы запиши номера соседей в conns, а сами длины перенеси в lens, пустые клетки замени нулём.
  3. Перебери все расстановки букв по номерам через permutations и оставь те, где каждая дорога есть в таблице.
  4. В подходящей расстановке найди номера нужных букв через p.index и возьми из lens сумму длин дорог B–A и H–A.
  5. Расстановок может быть несколько, если схема симметричная. Складывай результат в множество: ответ у них должен быть один.
from itertools import permutations

roads = 'AB AH BC BG CD CG DF EF EG FH'.split()
conns = ['47', '458', '67', '125', '246', '35', '138', '27']
lens = [
    [0, 0, 0, 16, 0, 0, 8, 0],
    [0, 0, 0, 23, 7, 0, 0, 15],
    [0, 0, 0, 0, 0, 19, 26, 0],
    [16, 23, 0, 0, 25, 0, 0, 0],
    [0, 7, 0, 25, 0, 38, 0, 0],
    [0, 0, 19, 0, 38, 0, 0, 0],
    [8, 0, 26, 0, 0, 0, 0, 19],
    [0, 15, 0, 0, 0, 0, 19, 0],
]

ans = set()
for p in permutations('ABCDEFGH'):
    if all(str(p.index(x) + 1) in conns[p.index(y)] for x, y in roads):
        ans.add(lens[p.index('B')][p.index('A')] + lens[p.index('H')][p.index('A')])
print(*ans)